
Creating and Deleting Groups

You can create a group in Program Manager to help organize your applications and documents. You can create 
personal groups and common groups. 

Important
To create or delete a common group, you must be logged on as a member of the Administrators, Server 

Operators, or Power Users group.

To create a group

1 From the File menu, choose New. 
2 In the New Program Object dialog box, select the Personal Program Group or Common Program Group

option, and then choose the OK button.
3 In the Description box in the Program Group Properties dialog box, type a description for the group. 

This description will appear in the title bar of the group window and below the group icon. 
4 Choose the OK button. 

To delete a group

1 Make sure the window of the group you want to delete is reduced to an icon. 
2 Select the icon. 
3 From the File menu, choose Delete. 

Or press DEL. 
4 In the Delete dialog box, choose the Yes button. 

Or press ENTER. 



Creating and Deleting Program Items

A program-item icon represents an application, accessory, or document in a program group. By choosing the 
icon for a program item, you start the application or accessory, or open the document. 
You can create a program item using the New command in File Manager, or you can create a program item by 
using a mouse to drag a program or document file from File Manager to a Program Manager group. 

Important
To create or delete a program item in a common group, you must be logged on as a member of the 

Administrators, Server Operators, or Power Users group.

To create a program item

1 Open the window of the group in which you want to place the program item. 
2 From the File menu, choose New. 
3 In the New Program Object dialog box, select the Program Item option, and then choose the OK button. 
4 Fill in the Program Item Properties dialog box as necessary, and then choose the OK button. 
For help with the Program Item Properties dialog box, choose the Help button or press F1 while using the 
dialog box. 

To delete a program item from a group

1 Select the icon for the item you want to delete. 
2 From the File menu, choose Delete. 

Or press DEL. 
3 In the Delete dialog box, choose the Yes button. 

Or press ENTER. 
When you delete an item from a group, you remove it from the group window, but not from your hard disk. 



Changing Properties

Once you have created a program item, personal group, or common group, you can go back and change its 
properties. For program items, you can change the description of the item, the working directory where files that
the application creates are stored, the shortcut key you use for switching to the application when it's running, 
the icon that Windows NT uses to represent the application, and whether the application is minimized to an icon 
whenever you start it. For a group, you can only change the description. 

Important 
To change the properties of a common group or a common group’s program items, you must be logged on 

as a member of the Administrators, Server Operators, or Power Users group.

To change the properties of a program item or group

1 Select the icon for the item or group. 
2 From the File menu, choose Properties. 

Or press ALT+ENTER. 
3 In the Program Item Properties dialog box, change properties as necessary. 
4 Choose the OK button. 
For help with the Program Item Properties dialog box, choose the Help button or press F1 while using the 
dialog box. 



Copying a Program Item

You can include a program item in more than one group by copying it to other groups. 

To copy a program item to another group

1 Open the group window that contains the program item you want to copy. 
2 Open the destination group window, or leave the destination group as an icon if you don't care where the icon 

for the copied item is placed. 
3 Press and hold down CTRL while dragging the program-item icon to the destination group window or icon. 
4 Release the mouse button and CTRL key when the copied icon is inside the destination group window or on top

of the destination group icon. 
If you release the mouse button and CTRL key when the icon is inside the source group window, Program 
Manager creates a duplicate program item in the source group. 

You can also copy a program item by choosing the Copy command from the File menu. 



Moving a Program Item

You can move a program item from one group to another.

Important
To move a program item from a common group, you must be logged on as a member of the 

Administrators, Server Operators, or Power Users group.

To move a program item to another group

1 Open the group window that contains the program item you want to move. 
2 Open the destination group window, or leave the destination group as an icon if you don't care where the icon 

for the moved item is placed. 
3 Drag the program-item icon to the destination group icon or window. 
4 Release the mouse button when the icon is on top of the destination group window or icon. 
You can also move a program item by choosing the Move command from the File menu. 



Arranging Group Windows

You can arrange your desktop so that windows and their contents are easy to see. The Tile command resizes 
and arranges the open group windows side by side in the Program Manager window. The Cascade command 
resizes and layers the open group windows so that each title bar is visible. 

To arrange group windows on your desktop
 From the Window menu, choose Cascade or Tile. 



Arranging Icons

You can arrange icons individually, all at once, or automatically. 

To arrange individual group or program-item icons
 Drag the icon to a new location using the mouse. 
Use the Arrange Icons command to evenly arrange icons all at once. 

To arrange program-item icons all at once
 Open the group window whose icons you want to arrange, and then, from the Window menu, choose 

Arrange Icons. 

To arrange group icons all at once
 Select any group icon, and then, from the Window menu, choose Arrange Icons. 
You can also specify that Windows NT automatically arrange the program-item icons in a group window 
whenever you change the window's size, add items, or move items. 

To automatically arrange program-item icons
 From the Options menu, choose Auto Arrange. 

A check mark next to the command means it is in effect. 



Changing an Icon

If more than one icon is available for a program item, you can change the icon. 

To change an icon

1 Select the icon you want to replace. 
2 From the File menu, choose Properties. 
3 In the Program Item Properties dialog box, choose the Change Icon button. 
4 Use one of the following methods to select a new icon:

If more than one icon is available, select a different icon in the Current Icon box. You can scroll through 
the icons by clicking the scroll arrows or by using the LEFT and RIGHT ARROW keys. 

If no additional icons are available, Windows NT displays the icons available with PROGMAN.EXE. Select an 
icon in the Current Icon box. 

In the File Name box, type the path to either PROGMAN.EXE or MORICONS.DLL, for example c:\winnt\
system32\moricons.dll, and then choose the OK button. Then select an icon in the Current Icon box.

5 Choose the OK button. 



Starting an Application from a Group

If an application belongs to a group, the easiest way to start it is to choose the program-item icon in the group 
window. If you associate a document with the program item, the document opens when you start the 
application. 

To start an application from a group

1 Open the group window that contains the application's program-item icon. 
2 Choose the program-item icon. (Double-click it, or choose Open from the File menu.) 



Starting an Application by Using the Run Command

You can use the Run command to start an application that you run only occasionally or have not yet added to a 
group. You can also open a document at the same time you start the application. 

To start an application by using the Run command

1 From the File menu, choose Run. 
2 In the Command Line box, type the path and name, including the extension, of the program file. 

You can also specify the name of a document to open. For example, to run Microsoft Word and open a 
document named STATUS.DOC, you would type c:\word\word.exe status.doc in the Command Line box. 

3 Select the Run Minimized check box if you want the application to be reduced to an icon whenever it starts. 
4 Select the Run in Separate Memory Space check box if the application is a Windows 3.1 application and 

you want to run it in a separate memory space from other Windows 3.1 applications.
5 Choose the OK button. 

Or press ENTER. 



Starting an Application When You Log On to Windows NT

When Windows NT Setup is run, a personal Startup group is created. When you add an application to the Startup
group, the application starts whenever you start Windows NT. You can add an application to a group by creating 
a program item or by copying or moving an existing program item. 



Running a Windows 3.1 Application in Separate Memory

When you start a Windows 3.1 application, by default it runs in the same memory space as other Windows 3.1 
applications. However, you can choose to run it in its own memory space, to prevent it from affecting other 
Windows 3.1 applications if it hangs or crashes. Because this uses more memory, you should do this only for 
applications that hang or crash regularly.
To run a Windows 3.1 application in its own memory space

When you create the program item for the application, select the Run in Separate Memory Space check
box.

Or select the Run in Separate Memory Space check box when you start the application using the Run 
command in the File menu.

See Also

Creating and Deleting Program Items 
Starting an Application by Using the Run Command 



Switching Between Applications

There are a number of ways to switch between applications. You can use any of the following methods. 
To switch to another application

Click anywhere in an application's inactive window. 
Press ALT+ESC until the window you want is active. 
Press and hold down ALT while pressing TAB repeatedly to cycle through running applications. 

When you release TAB, the application comes to the foreground. 
Press CTRL+ESC or double-click the desktop to open Task List. 

Select the application, and then choose the Switch To button. 
Or select the application, and then press ENTER. 

Choose Switch To from the Control menu of any running application. 
Choose the application's icon. 



Changing Your Password

Use the following procedure to change your Windows NT password.

To change your password

1 From anywhere in Windows NT, press CTRL+ALT+DEL.
2 Choose the Change Password button.

The Username and From boxes show the user name and location of the account you are currently logged on 
with.

3 In the Old Password box, type your current password.
4 In both the New Password and Confirm New Password boxes, type the new password you want.
5 Choose the OK button.



Locking Your Computer

If you want to leave your computer for a while, but you don't want to log off or halt programs that you have 
running, you can lock the computer. No other people will be able to use your computer while it is locked. When 
you return, you just type your password to regain use of the computer. 

To lock your computer

1 From anywhere in Windows NT, press CTRL+ALT+DEL.
2 Choose the Lock Workstation button.

The computer is then locked.

To unlock the computer

1 Press CTRL+ALT+DEL
2 Type your password in the Password box.



New

Adds a program item to a group or creates a group. After creating a group, you can add program items to it. 

Important
To create or add a program item to a common group, you must be logged on as a member of the 

Administrators, Server Operators, or Power Users group.
The New Program Object dialog box has the following options: 
Program Item

 Select the Program Item option to create an item in a group. 
Personal Program Group

 Select the Personal Program Group option to create a personal group. 
Common Program Group

 Select the Common Program Group option to create a common group. 



Open

Starts the selected application and opens an associated document, if there is one. 



Move

Moves a program item to another group. When you move a program item, it is removed from its original group. 

Important
To move a program item from a common group, you must be logged on as a member of the Administrators, 
Server Operators, or Power Users group.
The Move Program Item dialog box contains the following list box: 

To Group
 From the To Group list, select the group you want to move the selected item to. Then choose the OK 

button. (The name and current group of the selected program item appear at the top of the dialog box.) 



Copy

Copies an item to another group. When you copy an item, the original stays in the source group. You create a 
duplicate in the destination group. You can also copy a program item to a group by dragging the item onto the 
group icon or window. 
The Copy Program Item dialog box contains the following list box: 

To Group
 From the To Group list, select the group you want to move the selected item to. Then choose the OK 

button. (The name and current group of the selected program item appear at the top of the dialog box.) 



Delete

Deletes the selected group or program item. Deleting a group removes its program-item icons from Program 
Manager. The applications remain on your hard disk. 

Important
To delete a common group or program items in a common group, you must be logged on as a member of 

the Administrators, Server Operators, or Power Users group.



Properties

Changes the properties of a program item or group. The command line (path), working directory, and program-
item icon are all properties. 

Important
To change properties for a common group or for program items in a common group, you must be logged on

as a member of the Administrators, Server Operators, or Power Users group.
The dialog box that appears when you choose Properties depends on what you select. If you select a program 
item, the Program Item Properties dialog box appears. If you select a group, the Program Group 
Properties dialog box appears. 



Run

Starts an application or opens a document. 
The Run dialog box has the following options: 
Command Line

 Type the application filename, including the path, if necessary. 
If you want to open a document, type the application filename followed by a space and the name of the 
document.

If you don't know the name or location of the application or document file, use the Browse button to open the 
Browse dialog box. 
Run Minimized

 Select this check box if you want the application to be reduced to an icon every time it starts. 
Run in Separate Memory Space

 Select this check box if the application is a Windows 3.1 application and you want to run it in a separate 
memory space from other Windows 3.1 applications. 

See Also

Running a Windows 3.1 Application in Separate Memory 



Exit

Closes Program Manager.



Auto Arrange

Rearranges the program-item icons in a group window whenever you change the window's size, add items, or 
move items. A check mark next to the command means it is in effect. 



Minimize on Use

Reduces the Program Manager window to an icon whenever you start an application (unless the application 
starts as an icon). The icon is placed on the lower edge of the desktop, making it easy to find when you want to 
switch back to Program Manager. 



Save Settings Now

Saves the current arrangement of Program Manager windows and icons.



Save Settings on Exit

Saves the arrangement of Program Manager windows and icons. Newly created groups and program items are 
saved even if you do not select this command. 



Cascade

Arranges the open group windows in an overlapping pattern so that the title bar of each window is visible. 



Tile

Arranges the open group windows side by side so that all windows are visible. 



Arrange Icons

Arranges into rows all program-item icons for a selected group. If a group icon is selected when you choose this 
command, all group icons are arranged into rows. 



List of Groups

The names of all your groups are listed at the bottom of the Window menu. To open a group, choose its name 
from this list. 



Program Group Properties

Use this dialog box to define or change the description you want to appear below the group icon and in the 
group’s title bar.
Description

 Type the description. 



Program Item Properties

When you create a program item, you specify the program item's properties. Properties include such things as a 
description for the item, a working directory where any files that the application creates are stored, and the icon
that Windows NT uses to represent the application. After a program item has been created, you can go back and
change any of its properties. 
Choose one of the following buttons for information about the dialog box.
 Description
 Command Line
 Working Directory
 Shortcut Key
 Run Minimized
 Run in Separate Memory Space
 Change Icon Button

See Also

Changing Properties 
Changing an Icon 



Change Icon

Use this dialog box to change an icon or to view the icons available for the specified program item or group. The
filename for the selected item or group appears in the File Name box. 
File Name

 Type a new filename, if necessary. You can choose an icon from another application by typing the name of 
the program file for that application. To choose from a variety of Windows NT application icons, type Moricons.dll. 

Current Icon
 Scroll through the icons by clicking the scroll arrows or by using the LEFT and RIGHT ARROW keys. Select 

the icon you want to use, and then press ENTER or choose the OK button. 



Browse

Use this dialog box to easily find and select files. 
Choose one of the following buttons for information about the dialog box.
 File Name
 List Files of Type
 Directories

 Drives
 Network button



Control Menu

The Control menu has the following commands: 
Restore
Restores the window to its previous size after it has been maximized or minimized. 
Move
Enables you to use the keyboard to move the window to another position. 
Size
Enables you to use the keyboard to change the size of the window. 
Minimize
Reduces the window to an icon. 
Maximize
Enlarges the window to its maximum size. 
Close
Logs off from Windows NT or closes the window or dialog box. 
Switch To
Opens Task List, which you can use to switch between running applications and rearrange their windows and 
icons. 



Control Menu

The Control menu contains the following commands.
Restore
Restores the window to its former size after it has been maximized or minimized. 
Move
Enables you to use the keyboard to move the window to another position. 
Size
Enables you to use the keyboard to change the size of the window. 
Minimize
Reduces the window to an icon. 
Maximize
Enlarges the window to its maximum size. 
Close
Quits an application, or closes a window or dialog box. 
Next
Switches to the next window or icon. 



Contents

Starts Help and displays the topics in Program Manager Help. 



Search for Help on

Opens the Index tab for Help. You can look up Help information by using keywords on the tab.



How to Use Help

Describes how to use Help. 



About Program Manager

Displays version and copyright information about Windows NT. 



Description
 Type the name of the group or program item as you would like it to appear below the icon. 
The description is optional. If you leave this box blank, Program Manager names the icon for you. 



Command Line
 Type the name of the application's program file, including the extension and path, if necessary. 
If you don't know this information, use the Browse button to open the Browse dialog box. 



Working Directory
 Type the path of the directory where your application's program files and documents are located. 
The working directory is optional. If you leave this box blank when first creating the program item, the directory 
where the program file is located is the working directory. If you leave this box blank when changing a program 
item's properties, the Windows NT directory is the working directory. 



Shortcut Key
 Specify a unique key combination that, when pressed, makes the running application active. 
Valid key sequences are CTRL+ALT+character, CTRL+SHIFT+character, SHIFT+ALT+character, and 
CTRL+SHIFT+ALT+character. Character can be any letter, number, or special character. When you simply type a 
character in the Shortcut key area, Program Manager adds CTRL+ALT in front of it. To specify one of the other 
sequences, you must type it. 



Run Minimized
 Select this check box if you want the application to be reduced to an icon every time it starts. 



Run in Separate Memory Space
 This check box applies only to Windows 3.1 (16-bit) applications, and is inactive until you type the path of 

a Windows 3.1 application in the Command Line box. Select this check box if you want to run a Windows 3.1 
application in a separate memory space from other Windows 3.1 applications. Doing so protects other Windows 3.1 
applications if this application crashes, but uses more memory. You should select this check box only for 
applications that crash or hang regularly. 



Change Icon Button
 Choose this button to change a program icon for an item or group in Program Manager. 



File Name
 Select the name of the file you want, and then choose the OK button. 

Or type the filename in this box, and then choose the OK button. If necessary, also specify a path and drive. 
If the file you want does not appear in the File Name list, you can change drives or directories or specify a 
different type of file. 



List Files of Type
 Open the list, and then select the type of file you want displayed in the File Name box. 
For example, if you select Programs, the File Name list displays only program files (files with 
an .EXE, .PIF, .COM, or .BAT filename extension). 



Directories
 Select the directory that contains the program file you want to use. When you select a directory, the files in

that directory appear in the File Name box. 
If the directory you want does not appear in the list, you may have to change drives by choosing a different drive
from the Drives list. 



Drives
 Open the list and then select the drive that contains the file you want to use. When you change drives, the 

directories on that drive appear in the Directories box. 



Network button

Displays a dialog box that allows you to connect to shared directories on the network.



Program Not Found

Program Manager cannot find the program file in the path typed in the Command Line box. 
 Type the path of the program or choose the Locate button to browse the directory structure.



Locate

Use this dialog box to find and select the directory where the displayed program may be found.
Choose one of the following buttons for information about the dialog box.

 Directories
 Drives
 Network button



Directories
 Select the directory that contains the program file you want to use. 
If the directory you want does not appear in the list, you may have to change drives by choosing a different drive
from the Drives list.



Update Program Groups

Because the new program group format for Windows NT version 3.5 cannot be used on computers running 
Windows NT version 3.1, the program groups for both versions 3.5 and 3.1 are stored separately in your user 
profile. When you make changes to your program groups while running Windows NT version 3.1, these changes 
appear only when you are logged onto Windows NT version 3.1. Likewise, changes you make to program groups 
while running Windows NT version 3.5 appear only while you are running version 3.5.
You can continue using both formats, or if you are only using the Windows NT version 3.5 format, you can save 
disk space by deleting the old Windows NT version 3.1 format.

 Choose OK to delete the Windows NT version 3.1 program groups. Do this only if all the computers you use
have been updated to Windows NT version 3.5.

Or choose Cancel to continue using both formats. 



Assigning a Books Online Location

Use the Books Online dialog box to enter the location of the online books. After you assign a location, the Books
Online icon automatically opens up the online books. Books Online does not copy the online books to your 
computer. To copy the online books to your computer, you can use File Manager or the copy command at 
command prompt.

To assign a location for the online books
 In the Location of Books Online Files box, type the location of the files. The location can be on another 

computer, on a CD-ROM drive, or on the local computer.

To change the location of the online books

1 In Program Manager, from the File menu, choose Run.
2 In the command line box, type ntbooks. 

You can enter the following parameters for the ntbooks command:
/s Forces the command to access the Windows NT Server books.
/n Allows you to specify a new location for the online books. 
/w Forces the command to access the Windows NT Workstation books.



Installing Books Online Icon

When you upgrade from Windows NT Server or Windows NT Workstation version 3.5, the Books Online icon does 
not get installed in Program Manager. You can manually create the icon, then assign the location of the Books 
Online to the icon.

To install the Books Online icon

1 In Program Manager, from the File menu, choose New.
2 In the New box, choose Program Item, and then choose OK.
3 In the Program Item Properties dialog box, type Books Online in the Description box.
4 In the Command Line box, type ntbooks.exe.
5 In the Working Directory box type \SYSTEM32.
6 Choose the OK button.

See Also

Assigning a Books Online Location



Click Help Topics to see a list of Help topics. 




